Back to overview
Maintenance
[No disruption expected] Infrastructure maintenance of our telecom partner
May 7, 2026 at 12:00pm UTC
–
May 7, 2026 at 4:00pm UTC
Affected services
EBX API
EBX Control Center
EBX API v1
EBX Control Center API
Resolved
May 7, 2026 at 4:00pm UTC
Maintenance ended
Affected services
Created
May 7, 2026 at 12:00pm UTC
Our telecom partner has an upcoming maintenance work on their infrastructure. No service disruptions are expected.
Affected services